What’s Vulnerable › Vulnerabilities
CVE-2025-59028
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-27 · updated 2026-10-07
- Weakness: CWE-20
Description
When sending invalid base64 SASL data, login process is disconnected from the auth server, causing all active authentication sessions to fail. Invalid BASE64 data can be used to DoS a vulnerable server to break concurrent logins. Install fixed version or disable concurrency in login processes (heavy perfomance penalty on large deployments). No publicly available exploits are known.
Affected products
- dovecot: before 2.4.3 — fixed in 2.4.3
- Open-Xchange Dovecot: before 3.1.2 — fixed in 3.1.2
How to fix
Upgrade to a fixed version: dovecot 2.4.3; Open-Xchange Dovecot 3.1.2. Check the vendor advisory for mitigations.
References
- https://documentation.open-xchange.com/dovecot/security/advisories/csaf/2026/oxdc-adv-2026-0001.json
Get alerted when CVE-2025-59028 or the next vulnerability affects your stack