What’s Vulnerable › Vulnerabilities
CVE-2025-59030: Insufficient validation of incoming notifies over TCP can lead to a denial of service in Recursor
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-09 · updated 2026-10-07
- Weakness: CWE-276
Description
An attacker can trigger the removal of cached records by sending a NOTIFY query over TCP.
Affected products
- PowerDNS Recursor: from 5.1.0 before 5.1.9; from 5.2.0 before 5.2.7; from 5.3.0 before 5.3.3 — fixed in 5.1.9, 5.2.7, 5.3.3
How to fix
Upgrade to a fixed version: PowerDNS Recursor 5.1.9, 5.2.7, 5.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59030 or the next vulnerability affects your stack