What’s Vulnerable › Vulnerabilities
CVE-2025-59034: Indico may disclose unauthorized user details access via legacy API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-10 · updated 2026-06-17
- Weakness: CWE-639
Description
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).
Affected products
- indico: before 3.3.8 — fixed in 3.3.8
How to fix
Upgrade to a fixed version: indico 3.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/indico/indico/releases/tag/v3.3.8
- https://github.com/indico/indico/security/advisories/GHSA-4269-mcfh-cp7q
Get alerted when CVE-2025-59034 or the next vulnerability affects your stack