What’s Vulnerable › Vulnerabilities
CVE-2025-59036: Infrahub allows authentication with deleted and expired API tokens
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-09 · updated 2026-06-17
- Weakness: CWE-298
Description
Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.
Affected products
- opsmill infrahub: before 1.3.9; from 1.4.0, < 1.4.5
References
Get alerted when CVE-2025-59036 or the next vulnerability affects your stack