What’s Vulnerable › Vulnerabilities
CVE-2025-59041: Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-10 · updated 2026-06-17
- Weakness: CWE-94
Description
Claude Code is an agentic coding tool. At startup, Claude Code executed a command templated in with `git config user.email`. Prior to version 1.0.105, a maliciously configured user email in git could be used to trigger arbitrary code execution before a user accepted the workspace trust dialog. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.
Affected products
- anthropics claude-code: before 1.0.105 — fixed in 1.0.105
How to fix
Upgrade to a fixed version: anthropics claude-code 1.0.105. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59041 or the next vulnerability affects your stack