What’s Vulnerable › Vulnerabilities
CVE-2025-59059: Apache Ranger: Remote Code Execution Vulnerability in NashornScriptEngineCreator
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-03 · updated 2026-06-17
- Weakness: CWE-94
Description
Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache Ranger: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ranger 2.8.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/z47q86rho80390lf2qcmoc2josvs0gtv
- http://www.openwall.com/lists/oss-security/2026/03/02/5
Get alerted when CVE-2025-59059 or the next vulnerability affects your stack