What’s Vulnerable › Vulnerabilities
CVE-2025-59088: Python-kdcproxy: unauthenticated ssrf via realm‑controlled dns srv
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-12 · updated 2026-06-30
- Weakness: CWE-918
Description
If kdcproxy receives a request for a realm which does not have server addresses defined in its configuration, by default, it will query SRV records in the DNS zone matching the requested realm name. This creates a server-side request forgery vulnerability, since an attacker could send a request for a realm matching a DNS zone where they created SRV records pointing to arbitrary ports and hostnames (which may resolve to loopback or internal IP addresses). This vulnerability can be exploited to probe internal network topology and firewall rules, perform port scanning, and exfiltrate data. Deployments where the "use_dns" setting is explicitly set to false are not affected.
Affected products
- latchset kdcproxy: before 1.1.0 — fixed in 1.1.0
- Red Hat Enterprise Linux 10: all versions — fixed in 0:1.0.0-19.el10_1
- Red Hat Enterprise Linux 10.0 Extended Update Support: all versions — fixed in 0:1.0.0-19.el10_0
- Red Hat Enterprise Linux 7 Extended Lifecycle Support: all versions — fixed in 0:0.3.2-3.el7_9.3
- Red Hat Enterprise Linux 8: all versions — fixed in 8100020251028161822.823393f5, 8100020251103113748.143e9e98
- Red Hat Enterprise Linux 8.2 Advanced Update Support: all versions — fixed in 8020020251106022345.792f4060
- Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support: all versions — fixed in 8040020251103205102.5b01ab7e
- Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On: all versions — fixed in 8040020251103205102.5b01ab7e
- Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support: all versions — fixed in 8060020251030180424.ada582f1
- Red Hat Enterprise Linux 8.6 Telecommunications Update Service: all versions — fixed in 8060020251030180424.ada582f1
- Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions: all versions — fixed in 8060020251030180424.ada582f1
- Red Hat Enterprise Linux 8.8 Telecommunications Update Service: all versions — fixed in 8080020251029082621.b0a6ceea
- Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions: all versions — fixed in 8080020251029082621.b0a6ceea
- Red Hat Enterprise Linux 9: all versions — fixed in 0:1.0.0-9.el9_7
- Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions: all versions — fixed in 0:1.0.0-7.el9_0.1
- Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions: all versions — fixed in 0:1.0.0-7.el9_2.1
- Red Hat Enterprise Linux 9.4 Extended Update Support: all versions — fixed in 0:1.0.0-7.el9_4.1
- Red Hat Enterprise Linux 9.6 Extended Update Support: all versions — fixed in 0:1.0.0-9.el9_6
How to fix
Upgrade to a fixed version: latchset kdcproxy 1.1.0; Red Hat Enterprise Linux 10 0:1.0.0-19.el10_1; Red Hat Enterprise Linux 10.0 Extended Update Support 0:1.0.0-19.el10_0; Red Hat Enterprise Linux 7 Extended Lifecycle Support 0:0.3.2-3.el7_9.3; Red Hat Enterprise Linux 8 8100020251028161822.823393f5, 8100020251103113748.143e9e98; Red Hat Enterprise Linux 8.2 Advanced Update Support 8020020251106022345.792f4060; Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 8040020251103205102.5b01ab7e; Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On 8040020251103205102.5b01ab7e; Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support 8060020251030180424.ada582f1; Red Hat Enterprise Linux 8.6 Telecommunications Update Service 8060020251030180424.ada582f1; Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions 8060020251030180424.ada582f1; Red Hat Enterprise Linux 8.8 Telecommunications Update Service 8080020251029082621.b0a6ceea. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:21138
- https://access.redhat.com/errata/RHSA-2025:21139
- https://access.redhat.com/errata/RHSA-2025:21140
- https://access.redhat.com/errata/RHSA-2025:21141
- https://access.redhat.com/errata/RHSA-2025:21142
- https://access.redhat.com/errata/RHSA-2025:21448
- https://access.redhat.com/errata/RHSA-2025:21748
- https://access.redhat.com/errata/RHSA-2025:21806
- https://access.redhat.com/errata/RHSA-2025:21818
- https://access.redhat.com/errata/RHSA-2025:21819
- https://access.redhat.com/errata/RHSA-2025:21820
- https://access.redhat.com/errata/RHSA-2025:21821
Get alerted when CVE-2025-59088 or the next vulnerability affects your stack