What’s Vulnerable › Vulnerabilities
CVE-2025-59157: Coolify has Git Repository RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-05 · updated 2026-10-07
- Weakness: CWE-78
Description
Coolify is an open-source and self-hostable tool for managing servers, applications, and databases. Prior to version 4.0.0-beta.420.7, the Git Repository field during project creation is vulnerable to command injection. User input is not properly sanitized, allowing attackers to inject arbitrary shell commands that execute on the underlying server during the deployment workflow. A regular member user can exploit this vulnerability. Version 4.0.0-beta.420.7 contains a patch for the issue.
Affected products
- coollabsio coolify: before 4.0.0; 4.0.0-beta100, 4.0.0-beta101, 4.0.0-beta102, 4.0.0-beta103, 4.0.0-beta104, 4.0.0-beta105 (+401) — fixed in 4.0.0
How to fix
Upgrade to a fixed version: coollabsio coolify 4.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59157 or the next vulnerability affects your stack