What’s Vulnerable › Vulnerabilities

CVE-2025-59158: Coolify has Stored XSS in Project Name

Description

Coolify is an open-source and self-hostable tool for managing servers, applications, and databases. Coolify versions prior to and including v4.0.0-beta.420.6 are vulnerable to a stored cross-site scripting (XSS) attack in the project creation workflow. An authenticated user with low privileges (e.g., member role) can create a project with a maliciously crafted name containing embedded JavaScript. When an administrator later attempts to delete the project or its associated resource, the payload automatically executes in the admin’s browser context. Version 4.0.0-beta.420.7 contains a patch for the issue.

Affected products

How to fix

Upgrade to a fixed version: coollabsio coolify 4.0.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-59158 or the next vulnerability affects your stack