What’s Vulnerable › Vulnerabilities
CVE-2025-5916: Libarchive: integer overflow while reading warc files at archive_read_support_format_warc.c
- Severity: medium (CVSS 5.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-09 · updated 2026-09-01
- Weakness: CWE-190
Description
A vulnerability has been identified in the libarchive library. This flaw involves an integer overflow that can be triggered when processing a Web Archive (WARC) file that claims to have more than INT64_MAX - 4 content bytes. An attacker could craft a malicious WARC archive to induce this overflow, potentially leading to unpredictable program behavior, memory corruption, or a denial-of-service condition within applications that process such archives using libarchive. This bug affects libarchive versions prior to 3.8.0.
Affected products
- libarchive: before 3.8.0 — fixed in 3.8.0
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0, 9.0, 10.0
- Red Hat OpenShift Container Platform 4.18: 4.0
How to fix
Upgrade to a fixed version: libarchive 3.8.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-5916
- https://bugzilla.redhat.com/show_bug.cgi?id=2370872
- https://github.com/libarchive/libarchive/pull/2568
- https://github.com/libarchive/libarchive/releases/tag/v3.8.0
Get alerted when CVE-2025-5916 or the next vulnerability affects your stack