What’s Vulnerable › Vulnerabilities
CVE-2025-5918: Libarchive: reading past eof may be triggered for piped file streams
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-09 · updated 2026-09-01
- Weakness: CWE-125
Description
A vulnerability has been identified in the libarchive library. This flaw can be triggered when file streams are piped into bsdtar, potentially allowing for reading past the end of the file. This out-of-bounds read can lead to unintended consequences, including unpredictable program behavior, memory corruption, or a denial-of-service condition.
Affected products
- libarchive: before 3.8.0 — fixed in 3.8.0
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0, 9.0
- Red Hat OpenShift Container Platform 4.18: 4.0
How to fix
Upgrade to a fixed version: libarchive 3.8.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-5918
- https://bugzilla.redhat.com/show_bug.cgi?id=2370877
- https://github.com/libarchive/libarchive/pull/2584
- https://github.com/libarchive/libarchive/releases/tag/v3.8.0
Get alerted when CVE-2025-5918 or the next vulnerability affects your stack