What’s Vulnerable › Vulnerabilities
CVE-2025-5921: SureForms < 1.7.2 - Reflected XSS
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The SureForms WordPress plugin before 1.7.2 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against both authenticated and unauthenticated users.
Affected products
- brainstormforce SureForms – Contact Form, Payment Form & Other Custom Form Builder: before 1.7.2 — fixed in 1.7.2
How to fix
Upgrade to a fixed version: brainstormforce SureForms – Contact Form, Payment Form & Other Custom Form Builder 1.7.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-5921 or the next vulnerability affects your stack