What’s Vulnerable › Vulnerabilities
CVE-2025-59237: Microsoft SharePoint Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-14 · updated 2026-10-18
- Weakness: CWE-502
Description
Deserialization of untrusted data in Microsoft Office SharePoint allows an authorized attacker to execute code over a network.
Affected products
- Microsoft SharePoint Server: before 16.0.19127.20262; 2016, 2019 — fixed in 16.0.19127.20262
- Microsoft SharePoint Server Subscription Edition: from 16.0.0 before 16.0.19127.20262 — fixed in 16.0.19127.20262
- Microsoft Sharepoint Enterprise Server 2016: from 16.0.0 before 16.0.5522.1000 — fixed in 16.0.5522.1000
- Microsoft SharePoint Server: from 16.0.0 before 16.0.10417.20059 — fixed in 16.0.10417.20059
How to fix
Upgrade to a fixed version: Microsoft SharePoint Server 16.0.19127.20262; Microsoft SharePoint Server Subscription Edition 16.0.19127.20262; Microsoft Sharepoint Enterprise Server 2016 16.0.5522.1000; Microsoft SharePoint Server 16.0.10417.20059. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59237 or the next vulnerability affects your stack