What’s Vulnerable › Vulnerabilities
CVE-2025-59270: psPAS does not enforce TLS 1.2 within Get-PASSAMLResponse
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-16 · updated 2026-06-17
- Weakness: CWE-757
Description
psPAS PowerShell module does not explicitly enforce TLS 1.2 within the 'Get-PASSAMLResponse' function during the SAML authentication process. An unauthenticated attacker in a 'Man-in-the-Middle' position could manipulate the TLS handshake and downgrade TLS to a deprecated protocol. Fixed in 7.0.209.
Affected products
- pspete psPAS: from 6.4.85 before 7.0.209 — fixed in 7.0.209
How to fix
Upgrade to a fixed version: pspete psPAS 7.0.209. Check the vendor advisory for mitigations.
References
- https://github.com/pspete/psPAS/commit/2a8b1b4bc001bec9969ea512ed83386ed3e0b8f8#diff-e40bf02e86c8a8babbb20529ecaef6a069d8b5ea21701dca429dce78181109a7L37-R75
- https://github.com/pspete/psPAS/releases/tag/v7.0.209
- https://raw.githubusercontent.com/cisagov/CSAF/develop/csaf_files/IT/white/2025/va-25-258-01.json
- https://www.cve.org/CVERecord?id=CVE-2025-59270
Get alerted when CVE-2025-59270 or the next vulnerability affects your stack