What’s Vulnerable › Vulnerabilities
CVE-2025-59287: Microsoft Windows Server Update Service (WSUS) Deserialization of Untrusted Data Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-10-24
- EPSS: 100.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-14 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of untrusted data in Windows Server Update Service allows an unauthorized attacker to execute code over a network.
Affected products
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: before 10.0.14393.8524 — fixed in 10.0.14393.8524
- Microsoft Windows Server 2019: before 10.0.17763.7922 — fixed in 10.0.17763.7922
- Microsoft Windows Server 2022: before 10.0.20348.4297 — fixed in 10.0.20348.4297
- Microsoft Windows Server 2022, 23H2 Edition (Server Core installation): before 10.0.25398.1916 — fixed in 10.0.25398.1916
- Microsoft Windows Server 2025: before 10.0.26100.6905 — fixed in 10.0.26100.6905
How to fix
Upgrade to a fixed version: Microsoft Windows Server 2016 10.0.14393.8524; Microsoft Windows Server 2019 10.0.17763.7922; Microsoft Windows Server 2022 10.0.20348.4297; Microsoft Windows Server 2022, 23H2 Edition (Server Core installation) 10.0.25398.1916; Microsoft Windows Server 2025 10.0.26100.6905. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2025-59287
- https://hawktrace.com/blog/CVE-2025-59287
- https://www.bleepingcomputer.com/news/security/cisa-orders-feds-to-patch-windows-server-wsus-flaw-exploited-in-attacks/
- https://www.vicarius.io/vsociety/posts/cve-2025-59287-detection-script-rce-vulnerability-in-windows-server-update-service
- https://www.vicarius.io/vsociety/posts/cve-2025-59287-mitigation-script-rce-vulnerability-in-windows-server-update-service
- https://gist.github.com/hawktrace/880b54fb9c07ddb028baaae401bd3951
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-59287
Get alerted when CVE-2025-59287 or the next vulnerability affects your stack