What’s Vulnerable › Vulnerabilities
CVE-2025-59288: Playwright Spoofing Vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-14 · updated 2026-10-08
- Weakness: CWE-347
Description
Improper verification of cryptographic signature in Github: Playwright allows an unauthorized attacker to perform spoofing over an adjacent network.
Affected products
- microsoft/playwright: before 1.55.1 — fixed in 1.55.1
- microsoft/playwright: from 1.0.0 before 1.55.1 — fixed in 1.55.1
How to fix
Upgrade to a fixed version: microsoft/playwright 1.55.1; microsoft/playwright 1.55.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59288 or the next vulnerability affects your stack