What’s Vulnerable › Vulnerabilities
CVE-2025-59299: File Parsing Out-Of-Bounds Write Vulnerability in DIAScreen
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-03 · updated 2026-10-12
- Weakness: CWE-787
Description
Delta Electronics DIAScreen lacks proper validation of the user-supplied file. If a user opens a malicious file, an attacker can leverage this vulnerability to execute code in the context of the current process.
Affected products
- Delta Electronics DIAScreen: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: Delta Electronics DIAScreen 1.6.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59299 or the next vulnerability affects your stack