What’s Vulnerable › Vulnerabilities
CVE-2025-59303
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-08 · updated 2026-10-08
- Weakness: CWE-791
Description
HAProxy Kubernetes Ingress Controller before 3.1.13, when the config-snippets feature flag is used, accepts config snippets from users with create/update permissions. This can result in obtaining an ingress token secret as a response. The fixed versions of HAProxy Enterprise Kubernetes Ingress Controller are 3.0.16-ee1, 1.11.13-ee1, and 1.9.15-ee1.
Affected products
- HAProxy Technologies HAProxy Kubernetes Ingress Controller: before 3.1.13 — fixed in 3.1.13
How to fix
Upgrade to a fixed version: HAProxy Technologies HAProxy Kubernetes Ingress Controller 3.1.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59303 or the next vulnerability affects your stack