What’s Vulnerable › Vulnerabilities
CVE-2025-59305
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-24 · updated 2026-06-17
- Weakness: CWE-285
Description
Improper authorization in the background migration endpoints of Langfuse 3.1 before d67b317 allows any authenticated user to invoke migration control functions. This can lead to data corruption or denial of service through unauthorized access to TRPC endpoints such as backgroundMigrations.all, backgroundMigrations.status, and backgroundMigrations.retry.
Affected products
- langfuse: from 3.1.0 before 3.109.0 — fixed in 3.109.0
How to fix
Upgrade to a fixed version: langfuse 3.109.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59305 or the next vulnerability affects your stack