What’s Vulnerable › Vulnerabilities
CVE-2025-59334: Linkr allows manifest tampering leading to arbitrary file injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-16 · updated 2026-06-17
- Weakness: CWE-347
Description
Linkr is a lightweight file delivery system that downloads files from a webserver. Linkr versions through 2.0.0 do not verify the integrity or authenticity of .linkr manifest files before using their contents, allowing a tampered manifest to inject arbitrary file entries into a package distribution. An attacker can modify a generated .linkr manifest (for example by adding a new entry with a malicious URL) and when a user runs the extract command the client downloads the attacker-supplied file without verification. This enables arbitrary file injection and creates a potential path to remote code execution if a downloaded malicious binary or script is later executed. Version 2.0.1 adds a manifest integrity check that compares the checksum of the original author-created manifest to the one being extracted and aborts on mismatch, warning if no original manifest is hosted. Users should update to 2.0.1 or later. As a workaround prior to updating, use only trusted .linkr manifests, manually verify manifest integrity, and host manifests on trusted servers.
Affected products
- mohammadzain2008 Linkr: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: mohammadzain2008 Linkr 2.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/mohammadzain2008/Linkr/commit/182e5ddaa51972e144005b500c4bcebf2fd1a6c0
- https://github.com/mohammadzain2008/Linkr/security/advisories/GHSA-6wph-mpv2-29xv
- https://github.com/mohammadzain2008/Linkr/security/advisories/GHSA-6wph-mpv2-29xv
Get alerted when CVE-2025-59334 or the next vulnerability affects your stack