What’s Vulnerable › Vulnerabilities
CVE-2025-59336: Relative Path Traversal in Luanox
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-16 · updated 2026-06-17
- Weakness: CWE-22
Description
Luanox is a module host for Lua packages. Prior to 0.1.1, a file traversal vulnerability can cause potential denial of service by overwriting Phoenix runtime files. Package names like ../../package are not properly filtered and pass the validity check of the rockspec verification system. This causes the uploaded file to be stored at the relative path location. If planned carefully, this could overwrite a runtime file and cause the website to crash. This vulnerability is fixed by 0.1.1.
Affected products
- lumen-oss luanox: before 0.1.1
References
- https://github.com/lumen-oss/luanox/commit/2b6237f3baaa1d905c491fca29f8301835721c46
- https://github.com/lumen-oss/luanox/commit/5198640c9644e2fcef5809f83b9ab0a9b4d0eeb2
- https://github.com/lumen-oss/luanox/security/advisories/GHSA-42c5-x4pj-4p3w
Get alerted when CVE-2025-59336 or the next vulnerability affects your stack