What’s Vulnerable › Vulnerabilities
CVE-2025-59337: Discourse: Cross-Site Data Exposure via Backup Restore Metacommand Injection in Multisite Deployments
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-10-19
- Weakness: CWE-77
Description
Discourse is an open-source community discussion platform. In versions 3.5.0 and below, malicious meta-commands could be embedded in a backup dump and executed during restore. In multisite setups, this allowed an admin of one site to access data or credentials from other sites. This issue is fixed in version 3.5.1.
Affected products
- discourse: before 3.5.1; before 3.6.0; 3.6.0-beta1 — fixed in 3.5.1, 3.6.0
How to fix
Upgrade to a fixed version: discourse 3.5.1, 3.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/43536b60d012cc8084e7e701d6afab9ba01e28a5
- https://github.com/discourse/discourse/security/advisories/GHSA-7xjr-4f4g-9887
Get alerted when CVE-2025-59337 or the next vulnerability affects your stack