What’s Vulnerable › Vulnerabilities
CVE-2025-5935: Open5GS AMF/MME emm-sm.c common_register_state denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-10 · updated 2026-06-17
- Weakness: CWE-404
Description
A vulnerability was found in Open5GS up to 2.7.3. It has been declared as problematic. Affected by this vulnerability is the function common_register_state of the file src/mme/emm-sm.c of the component AMF/MME. The manipulation of the argument ran_ue_id leads to denial of service. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. The identifier of the patch is 62cb99755243c9c38e4c060c5d8d0e158fe8cdd5. It is recommended to apply a patch to fix this issue.
Affected products
- Open5GS: before 2.7.6 — fixed in 2.7.6
How to fix
Upgrade to a fixed version: Open5GS 2.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/open5gs/open5gs/commit/62cb99755243c9c38e4c060c5d8d0e158fe8cdd5
- https://github.com/open5gs/open5gs/issues/3874
- https://github.com/open5gs/open5gs/issues/3874#issuecomment-2853547622
- https://github.com/user-attachments/files/19863206/Problematic.handover.required.process.zip
- https://vuldb.com/?ctiid.311713
- https://vuldb.com/?id.311713
- https://vuldb.com/?submit.589354
Get alerted when CVE-2025-5935 or the next vulnerability affects your stack