What’s Vulnerable › Vulnerabilities
CVE-2025-5937: MicroPayments – Fans Paysite: Paid Creator Subscriptions, Digital Assets, Wallet <= 3.2.0 - Cross-Site Request Forgery to Settings Reset
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-28 · updated 2026-06-17
- Weakness: CWE-352
Description
The MicroPayments – Fans Paysite: Paid Creator Subscriptions, Digital Assets, Wallet plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.2.0. This is due to missing or incorrect nonce validation on the adminOptions() function. This makes it possible for unauthenticated attackers to reset the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- videowhisper MicroPayments: before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: videowhisper MicroPayments 3.2.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/paid-membership/trunk/inc/options.php#L1364
- https://plugins.trac.wordpress.org/changeset/3318389/#file0
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d80417bc-2bb2-4826-be03-796a7cd2825f?source=cve
Get alerted when CVE-2025-5937 or the next vulnerability affects your stack