What’s Vulnerable › Vulnerabilities
CVE-2025-59388: Hyper Data Protector
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-12 · updated 2026-06-17
- Weakness: CWE-259
Description
A use of hard-coded password vulnerability has been reported to affect Hyper Data Protector. The remote attackers can then exploit the vulnerability to gain unauthorized access. We have already fixed the vulnerability in the following version: Hyper Data Protector 2.3.1.455 and later
Affected products
- QNAP Systems Inc. Hyper Data Protector: from 2.2.0.284 before 2.3.1.455 — fixed in 2.3.1.455
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Hyper Data Protector 2.3.1.455. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59388 or the next vulnerability affects your stack