What’s Vulnerable › Vulnerabilities
CVE-2025-59389: Hyper Data Protector
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-02 · updated 2026-10-14
- Weakness: CWE-89
Description
An SQL injection vulnerability has been reported to affect Hyper Data Protector. The remote attackers can then exploit the vulnerability to execute unauthorized code or commands. We have already fixed the vulnerability in the following versions: Hyper Data Protector 2.2.4.1 and later
Affected products
- QNAP Systems Inc. Hyper Data Protector: from 2.1.0.0226 before 2.2.4.1; 2.0.0.1115-beta — fixed in 2.2.4.1
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Hyper Data Protector 2.2.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59389 or the next vulnerability affects your stack