What’s Vulnerable › Vulnerabilities
CVE-2025-59390: Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly.
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-26 · updated 2026-06-17
- Weakness: CWE-338
Description
Apache Druid’s Kerberos authenticator uses a weak fallback secret when the `druid.auth.authenticator.kerberos.cookieSignatureSecret` configuration is not explicitly set. In this case, the secret is generated using `ThreadLocalRandom`, which is not a crypto-graphically secure random number generator. This may allow an attacker to predict or brute force the secret used to sign authentication cookies, potentially enabling token forgery or authentication bypass. Additionally, each process generates its own fallback secret, resulting in inconsistent secrets across nodes. This causes authentication failures in distributed or multi-broker deployments, effectively leading to a incorrectly configured clusters. Users are advised to configure a strong `druid.auth.authenticator.kerberos.cookieSignatureSecret` This issue affects Apache Druid: through 34.0.0. Users are recommended to upgrade to version 35.0.0, which fixes the issue making it mandatory to set `druid.auth.authenticator.kerberos.cookieSignatureSecret` when using the Kerberos authenticator. Services will fail to come up if the secret is not set.
Affected products
- Apache Software Foundation Apache Druid: before 35.0.0 — fixed in 35.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Druid 35.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/jwjltllnntgj1sb9wzsjmvwm9f8rlhg8
- http://www.openwall.com/lists/oss-security/2025/11/26/1
Get alerted when CVE-2025-59390 or the next vulnerability affects your stack