What’s Vulnerable › Vulnerabilities
CVE-2025-59391
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-08 · updated 2026-10-19
- Weakness: CWE-125
Description
A memory disclosure vulnerability exists in libcoap's OSCORE configuration parser in libcoap before release-4.3.5-patches. An out-of-bounds read may occur when parsing certain configuration values, allowing an attacker to infer or read memory beyond string boundaries in the .rodata section. This could potentially lead to information disclosure or denial of service.
Affected products
- libcoap: before 4.3.5a — fixed in 4.3.5a
How to fix
Upgrade to a fixed version: libcoap 4.3.5a. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59391 or the next vulnerability affects your stack