What’s Vulnerable › Vulnerabilities
CVE-2025-59398
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-06-17
- Weakness: CWE-392
Description
The OCPP implementation in libocpp before 0.26.2 allows a denial of service (EVerest crash) via JSON input larger than 255 characters, because a CiString<255> object is created with StringTooLarge set to Throw.
Affected products
- EVerest libocpp: before 0.26.2 — fixed in 0.26.2
How to fix
Upgrade to a fixed version: EVerest libocpp 0.26.2. Check the vendor advisory for mitigations.
References
- https://github.com/EVerest/everest-core/commit/253432ae7458ad0445f68f9d716086090c2be49c
- https://github.com/EVerest/everest-core/issues/1152
- https://github.com/EVerest/libocpp/commit/fb391b4ff16a0a07150e5a8eebf0856fb6623cbe
- https://github.com/EVerest/libocpp/compare/v0.26.1...v0.26.2
- https://github.com/EVerest/libocpp/pull/1052
Get alerted when CVE-2025-59398 or the next vulnerability affects your stack