What’s Vulnerable › Vulnerabilities
CVE-2025-59399
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-06-17
- Weakness: CWE-460
Description
libocpp before 0.28.0 allows a denial of service (EVerest crash) because a secondary exception is thrown during error message generation.
Affected products
- EVerest libocpp: before 0.28.0 — fixed in 0.28.0
How to fix
Upgrade to a fixed version: EVerest libocpp 0.28.0. Check the vendor advisory for mitigations.
References
- https://github.com/EVerest/libocpp/commit/0b84d7f9fb3c338d470770f220a7b7f21db78878
- https://github.com/EVerest/libocpp/compare/v0.27.1...v0.28.0
Get alerted when CVE-2025-59399 or the next vulnerability affects your stack