What’s Vulnerable › Vulnerabilities
CVE-2025-5940: Osom Blocks <= 1.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via class_name Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Osom Blocks – Custom Post Type listing block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘class_name’ parameter in all versions up to, and including, 1.2.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- osompress Osom Blocks: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: osompress Osom Blocks 1.2.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/osomblocks/trunk/blocks/cpt-list/index.php#L171
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3320673%40osomblocks&new=3320673%40osomblocks&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/osomblocks/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/54e022df-0dc7-4f60-811d-48a92b723d55?source=cve
Get alerted when CVE-2025-5940 or the next vulnerability affects your stack