What’s Vulnerable › Vulnerabilities
CVE-2025-59417: Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Lobe Chat is an open-source artificial intelligence chat framework. Prior to version 1.129.4, there is a a cross-site scripting (XSS) vulnerability when handling chat message in lobe-chat that can be escalated to remote code execution on the user’s machine. In lobe-chat, when the response from the server is like <lobeArtifact identifier="ai-new-interpretation" ...> , it will be rendered with the lobeArtifact node, instead of the plain text. However, when the type of the lobeArtifact is image/svg+xml , it will be rendered as the SVGRender component, which internally uses dangerouslySetInnerHTML to set the content of the svg, resulting in XSS attack. Any party capable of injecting content into chat messages, such as hosting a malicious page for prompt injection, operating a compromised MCP server, or leveraging tool integrations, can exploit this vulnerability. This vulnerability is fixed in 1.129.4.
Affected products
- lobehub lobe-chat: before 1.129.4 — fixed in 1.129.4
How to fix
Upgrade to a fixed version: lobehub lobe-chat 1.129.4. Check the vendor advisory for mitigations.
References
- https://github.com/lobehub/lobe-chat/commit/9f044edd07ce102fe9f4b2fb47c62191c36da05c
- https://github.com/lobehub/lobe-chat/security/advisories/GHSA-m79r-r765-5f9j
- https://github.com/lobehub/lobe-chat/security/advisories/GHSA-m79r-r765-5f9j
Get alerted when CVE-2025-59417 or the next vulnerability affects your stack