What’s Vulnerable › Vulnerabilities
CVE-2025-59418: BunnyPad Vulnerable to Buffer Overflow When Opening Files of Size 20MB or Greater
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-22 · updated 2026-06-17
- Weakness: CWE-770
Description
BunnyPad is a note taking software. Prior to version 11.0.27000.0915, opening files greater than or equal to 20MB causes buffer overflow to occur. This issue has been patched in version 11.0.27000.0915. Users who wish not to upgrade should refrain from opening files larger than 10MB.
Affected products
- GSYT-Productions BunnyPad-SRC: before 11.0.27000.0915
References
- https://github.com/GSYT-Productions/BunnyPad-SRC/commit/d9224eb5e13c24ac148a77dff93e53c21f066533
- https://github.com/GSYT-Productions/BunnyPad-SRC/security/advisories/GHSA-qhw4-c7x5-vxmj
Get alerted when CVE-2025-59418 or the next vulnerability affects your stack