What’s Vulnerable › Vulnerabilities
CVE-2025-59424: LinkAce Vulnerable to Stored XSS on the Audit Page
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-18 · updated 2026-06-17
- Weakness: CWE-79
Description
LinkAce is a self-hosted archive to collect website links. Prior to 2.3.1, a Stored Cross-Site Scripting (XSS) vulnerability has been identified on the /system/audit page. The application fails to properly sanitize the username field before it is rendered in the audit log. An authenticated attacker can set a malicious JavaScript payload as their username. When an action performed by this user is recorded (e.g., generate or revoke an API token), the payload is stored in the database. The script is then executed in the browser of any user, particularly administrators, who views the /system/audit page. This vulnerability is fixed in 2.3.1.
Affected products
- Kovah LinkAce: before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: Kovah LinkAce 2.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/Kovah/LinkAce/commit/c0d21b974b32f1ca2fab550fb476c573a068e196
- https://github.com/Kovah/LinkAce/security/advisories/GHSA-289g-9gff-p4wh
Get alerted when CVE-2025-59424 or the next vulnerability affects your stack