What’s Vulnerable › Vulnerabilities
CVE-2025-59425: vLLM vulnerable to timing attack at bearer auth
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-07 · updated 2026-10-19
- Weakness: CWE-385
Description
vLLM is an inference and serving engine for large language models (LLMs). Before version 0.11.0rc2, the API key support in vLLM performs validation using a method that was vulnerable to a timing attack. API key validation uses a string comparison that takes longer the more characters the provided API key gets correct. Data analysis across many attempts could allow an attacker to determine when it finds the next correct character in the key sequence. Deployments relying on vLLM's built-in API key validation are vulnerable to authentication bypass using this technique. Version 0.11.0rc2 fixes the issue.
Affected products
- vllm-project vllm: before 0.11.0; 0.11.0-rc1 — fixed in 0.11.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/blob/4b946d693e0af15740e9ca9c0e059d5f333b1083/vllm/entrypoints/openai/api_server.py#L1270-L1274
- https://github.com/vllm-project/vllm/commit/ee10d7e6ff5875386c7f136ce8b5f525c8fcef48
- https://github.com/vllm-project/vllm/releases/tag/v0.11.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-wr9h-g72x-mwhm
Get alerted when CVE-2025-59425 or the next vulnerability affects your stack