What’s Vulnerable › Vulnerabilities
CVE-2025-59427: Cloudflare vite plugin exposes secrets over the built-in dev server
- Severity: low (CVSS 2.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-19 · updated 2026-06-17
- Weakness: CWE-200
Description
The Cloudflare Vite plugin enables a full-featured integration between Vite and the Workers runtime. When utilising the Cloudflare Vite plugin in its default configuration, all files are exposed by the local dev server, including files in the root directory that contain secret information such as .env and .dev.vars. This vulnerability is fixed in 1.6.0.
Affected products
- cloudflare workers-sdk: before 1.6.0
References
- https://github.com/cloudflare/workers-sdk/commit/0e500720bf70016fa4ea21fc8959c4bd764ebc38
- https://github.com/cloudflare/workers-sdk/discussions/3455#discussioncomment-6165773
- https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-4pfg-2mw5-f8jx
- https://hackerone.com/reports/3117837
Get alerted when CVE-2025-59427 or the next vulnerability affects your stack