What’s Vulnerable › Vulnerabilities
CVE-2025-59429: FreePBX core module vulnerable to reflected cross-site scripting via Asterisk HTTP Status page
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-14 · updated 2026-10-08
- Weakness: CWE-79
Description
FreePBX is an open source GUI for managing Asterisk. In versions prior to 16.0.68.39 for FreePBX 16 and versions prior to 17.0.18.38 for FreePBX 17, a reflected cross-site scripting vulnerability is present on the Asterisk HTTP Status page. The Asterisk HTTP status page is exposed by FreePBX and is available by default on version 16 via any bound IP address at port 8088. By default on version 17, the binding is only to localhost IP, making it significantly less vulnerable. The vulnerability can be exploited by unauthenticated attackers to obtain cookies from logged-in users, allowing them to hijack a session of an administrative user. The theft of admin session cookies allows attackers to gain control over the FreePBX admin interface, enabling them to access sensitive data, modify system configurations, create backdoor accounts, and cause service disruption. This issue has been patched in version 16.0.68.39 for FreePBX 16 and version 17.0.18.38 for FreePBX 17.
Affected products
- Sangoma FreePBX: before 16.0.68.39; from 17.0.1 before 17.0.18.38 — fixed in 16.0.68.39, 17.0.18.38
How to fix
Upgrade to a fixed version: Sangoma FreePBX 16.0.68.39, 17.0.18.38. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59429 or the next vulnerability affects your stack