What’s Vulnerable › Vulnerabilities
CVE-2025-59454: Apache CloudStack: Lack of user permission validation leading to data leak for few APIs
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-27 · updated 2026-10-18
- Weakness: CWE-200
Description
In Apache CloudStack, a gap in access control checks affected the APIs - createNetworkACL - listNetworkACLs - listResourceDetails - listVirtualMachinesUsageHistory - listVolumesUsageHistory While these APIs were accessible only to authorized users, insufficient permission validation meant that users could occasionally access information beyond their intended scope. Users are recommended to upgrade to Apache CloudStack 4.20.2.0 or 4.22.0.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache CloudStack: from 4.0.0 before 4.20.2.0; 4.21.0.0 — fixed in 4.20.2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.20.2.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/0hlklvlwhzsfw39nocmyxb6svjbs9xbc
- http://www.openwall.com/lists/oss-security/2025/11/27/3
Get alerted when CVE-2025-59454 or the next vulnerability affects your stack