What’s Vulnerable › Vulnerabilities
CVE-2025-59465
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-20 · updated 2026-07-15
- Weakness: CWE-400
Description
A malformed `HTTP/2 HEADERS` frame with oversized, invalid `HPACK` data can cause Node.js to crash by triggering an unhandled `TLSSocket` error `ECONNRESET`. Instead of safely closing the connection, the process crashes, enabling a remote denial of service. This primarily affects applications that do not attach explicit error handlers to secure sockets, for example: ``` server.on('secureConnection', socket => { socket.on('error', err => { console.log(err) }) }) ```
Affected products
- Node.js: from 20.0.0 before 20.20.0; from 22.0.0 before 22.22.0; from 24.0.0 before 24.13.0; from 25.0.0 before 25.3.0 — fixed in 20.20.0, 22.22.0, 24.13.0, 25.3.0
How to fix
Upgrade to a fixed version: Node.js 20.20.0, 22.22.0, 24.13.0, 25.3.0. Check the vendor advisory for mitigations.
References
- https://nodejs.org/en/blog/vulnerability/december-2025-security-releases
- https://access.redhat.com/errata/RHSA-2026:1842
- https://access.redhat.com/errata/RHSA-2026:1843
- https://access.redhat.com/errata/RHSA-2026:2420
- https://access.redhat.com/errata/RHSA-2026:2421
- https://access.redhat.com/errata/RHSA-2026:2422
- https://access.redhat.com/errata/RHSA-2026:2767
- https://access.redhat.com/errata/RHSA-2026:2768
- https://access.redhat.com/errata/RHSA-2026:2781
- https://access.redhat.com/errata/RHSA-2026:2782
- https://access.redhat.com/errata/RHSA-2026:2783
- https://access.redhat.com/errata/RHSA-2026:2864
Get alerted when CVE-2025-59465 or the next vulnerability affects your stack