What’s Vulnerable › Vulnerabilities
CVE-2025-59471: Next.js self-hosted applications vulnerable to DoS via Image Optimizer remotePatterns configuration
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-26 · updated 2026-06-17
- Weakness: CWE-400
Description
A denial of service vulnerability exists in self-hosted Next.js applications that have `remotePatterns` configured for the Image Optimizer. The image optimization endpoint (`/_next/image`) loads external images entirely into memory without enforcing a maximum size limit, allowing an attacker to cause out-of-memory conditions by requesting optimization of arbitrarily large images. This vulnerability requires that `remotePatterns` is configured to allow image optimization from external domains and that the attacker can serve or control a large image on an allowed domain. Strongly consider upgrading to 15.5.10 or 16.1.5 to reduce risk and prevent availability issues in Next applications.
Affected products
- Next.js: from 10.0.0 before 15.5.10; from 16.0.0 before 16.1.5 — fixed in 15.5.10, 16.1.5
- Npm Next: from 10.0.0 before 15.5.10; from 15.6.0-canary.0 before 16.1.5 — fixed in 15.5.10, 16.1.5
How to fix
Upgrade to a fixed version: Next.js 15.5.10, 16.1.5; Npm Next 15.5.10, 16.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59471 or the next vulnerability affects your stack