What’s Vulnerable › Vulnerabilities

CVE-2025-59475

Description

Jenkins 2.527 and earlier, LTS 2.516.2 and earlier does not perform a permission check for the authenticated user profile dropdown menu, allowing attackers without Overall/Read permission to obtain limited information about the Jenkins configuration by listing available options in this menu (e.g., whether Credentials Plugin is installed).

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.516.3, 2.528. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-59475 or the next vulnerability affects your stack