What’s Vulnerable › Vulnerabilities

CVE-2025-59476

Description

Jenkins 2.527 and earlier, LTS 2.516.2 and earlier does not restrict or transform the characters that can be inserted from user-specified content in log messages, allowing attackers able to control log message contents to insert line break characters, followed by forged log messages that may mislead administrators reviewing log output.

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.516.3, 2.528. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-59476 or the next vulnerability affects your stack