What’s Vulnerable › Vulnerabilities
CVE-2025-59489
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-03 · updated 2026-10-08
- Weakness: CWE-88
Description
Unity Runtime before 2025-10-02 on Android, Windows, macOS, and Linux allows argument injection that can result in loading of library code from an unintended location. If an application was built with a version of Unity Editor that had the vulnerable Unity Runtime code, then an adversary may be able to execute code on, and exfiltrate confidential information from, the machine on which that application is running. NOTE: product status is provided for Unity Editor because that is the information available from the Supplier. However, updating Unity Editor typically does not address the effects of the vulnerability; instead, it is necessary to rebuild and redeploy all affected applications.
Affected products
- Unity3D Unity Editor: from 2017.4 through 2018.4; from 2019.1 before 2019.1.15f1; from 2019.2 before 2019.2.23f1; from 2019.3 through 2019.3.17f1; from 2019.4 before 2019.4.41f1; from 2020.1 before 2020.1.18f1 — fixed in 2019.1.15f1, 2019.2.23f1, 2019.4.41f1, 2020.1.18f1, 2020.2.8f1, 2020.3.49f1
How to fix
Upgrade to a fixed version: Unity3D Unity Editor 2019.1.15f1, 2019.2.23f1, 2019.4.41f1, 2020.1.18f1. Check the vendor advisory for mitigations.
References
- https://flatt.tech/research/posts/arbitrary-code-execution-in-unity-runtime/
- https://unity.com/security#security-updates-and-patches
- https://unity.com/security/sept-2025-01
Get alerted when CVE-2025-59489 or the next vulnerability affects your stack