What’s Vulnerable › Vulnerabilities
CVE-2025-5950: IndieBlocks <= 0.13.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via kind Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The IndieBlocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘kind’ parameter in all versions up to, and including, 0.13.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- janboddez IndieBlocks: before 0.13.3 — fixed in 0.13.3
How to fix
Upgrade to a fixed version: janboddez IndieBlocks 0.13.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/indieblocks/trunk/blocks/facepile-content/render.php#L39
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3311358%40indieblocks&new=3311358%40indieblocks&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/indieblocks/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/41fdb3ea-1de4-4b90-a387-5932de7a5e7c?source=cve
Get alerted when CVE-2025-5950 or the next vulnerability affects your stack