What’s Vulnerable › Vulnerabilities
CVE-2025-59537: argo-cd is vulnerable to unauthenticated DoS attack via malformed Gogs webhook payload
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-01 · updated 2026-10-12
- Weakness: CWE-20
Description
Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Versions 1.2.0 through 1.8.7, 2.0.0-rc1 through 2.14.19, 3.0.0-rc1 through 3.2.0-rc1, 3.1.7 and 3.0.18 are vulnerable to malicious API requests which can crash the API server and cause denial of service to legitimate clients. With the default configuration, no webhook.gogs.secret set, Argo CD’s /api/webhook endpoint will crash the entire argocd-server process when it receives a Gogs push event whose JSON field commits[].repo is not set or is null. This issue is fixed in versions 2.14.20, 3.2.0-rc2, 3.1.8 and 3.0.19.
Affected products
- argoproj argo-cd: from 1.2.0 through 1.8.7; from 2.0.0 before 2.14.20; from 3.0.0 before 3.0.19; from 3.1.0 before 3.1.8; 3.2.0-rc1 — fixed in 2.14.20, 3.0.19, 3.1.8
How to fix
Upgrade to a fixed version: argoproj argo-cd 2.14.20, 3.0.19, 3.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/argoproj/argo-cd/commit/761fc27068d2d4cd24e1f784eb2a9033b5ee7f43
- https://github.com/argoproj/argo-cd/security/advisories/GHSA-wp4p-9pxh-cgx2
- https://github.com/argoproj/argo-cd/security/advisories/GHSA-wp4p-9pxh-cgx2
Get alerted when CVE-2025-59537 or the next vulnerability affects your stack