What’s Vulnerable › Vulnerabilities
CVE-2025-59546: DNN Vulnerable to Stored XSS Using Backend Admin Credentials
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-23 · updated 2026-10-11
- Weakness: CWE-79
Description
DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 10.1.0, administrators and content editors can set html in module titles that could include javascript which could be used for XSS based attacks. This issue has been patched in version 10.1.0.
Affected products
- DotNetNuke CMS Fixed in 9.1.1: before 10.1.0 — fixed in 10.1.0
How to fix
Upgrade to a fixed version: DotNetNuke CMS Fixed in 9.1.1 10.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59546 or the next vulnerability affects your stack