What’s Vulnerable › Vulnerabilities
CVE-2025-5961: Migration, Backup, Staging – WPvivid Backup & Migration <= 0.9.116 - Authenticated (Administrator+) Arbitrary File Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 55.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-03 · updated 2026-06-17
- Weakness: CWE-434
Description
The Migration, Backup, Staging – WPvivid Backup & Migration plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'wpvivid_upload_import_files' function in all versions up to, and including, 0.9.116. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. NOTE: Uploaded files are only accessible on WordPress instances running on the NGINX web server as the existing .htaccess within the target file upload folder prevents access on Apache servers.
Affected products
- wpvividplugins WPvivid — Backup, Migration & Staging: before 0.9.117 — fixed in 0.9.117
How to fix
Upgrade to a fixed version: wpvividplugins WPvivid — Backup, Migration & Staging 0.9.117. Check the vendor advisory for mitigations.
References
- https://github.com/d0n601/CVE-2025-5961
- https://plugins.trac.wordpress.org/browser/wpvivid-backuprestore/trunk/includes/class-wpvivid-export-import.php#L2210
- https://plugins.trac.wordpress.org/browser/wpvivid-backuprestore/trunk/includes/class-wpvivid-export-import.php#L2235
- https://plugins.trac.wordpress.org/browser/wpvivid-backuprestore/trunk/includes/class-wpvivid-export-import.php#L2246
- https://plugins.trac.wordpress.org/changeset/3320877/
- https://ryankozak.com/posts/cve-2025-5961/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d8ceb4a1-9354-4ed3-9a8f-45ba2057a810?source=cve
Get alerted when CVE-2025-5961 or the next vulnerability affects your stack