What’s Vulnerable › Vulnerabilities

CVE-2025-59681

Description

An issue was discovered in Django 4.2 before 4.2.25, 5.1 before 5.1.13, and 5.2 before 5.2.7. QuerySet.annotate(), QuerySet.alias(), QuerySet.aggregate(), and QuerySet.extra() are subject to SQL injection in column aliases, when using a suitably crafted dictionary, with dictionary expansion, as the **kwargs passed to these methods (on MySQL and MariaDB).

Affected products

How to fix

Upgrade to a fixed version: Django 4.2.25, 5.1.13, 5.2.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-59681 or the next vulnerability affects your stack