What’s Vulnerable › Vulnerabilities
CVE-2025-59689: Libraesva Email Security Gateway Command Injection Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-09-29
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-19 · updated 2026-06-17
- Weakness: CWE-77
Description
Libraesva ESG 4.5 through 5.5.x before 5.5.7 allows command injection via a compressed e-mail attachment. For ESG 5.0 a fix has been released in 5.0.31. For ESG 5.1 a fix has been released in 5.1.20. For ESG 5.2 a fix has been released in 5.2.31. For ESG 5.4 a fix has been released in 5.4.8. For ESG 5.5. a fix has been released in 5.5.7.
Affected products
- Libraesva Email Security Gateway: from 4.5 before 5.0.31; from 5.1.0 before 5.1.20; from 5.2.0 before 5.2.31; from 5.3.0 before 5.3.16; from 5.4.0 before 5.4.8; from 5.5.0 before 5.5.7 — fixed in 5.0.31, 5.1.20, 5.2.31, 5.3.16, 5.4.8, 5.5.7
How to fix
Upgrade to a fixed version: Libraesva Email Security Gateway 5.0.31, 5.1.20, 5.2.31, 5.3.16. Check the vendor advisory for mitigations.
References
- https://docs.libraesva.com/knowledgebase/security-advisory-command-injection-vulnerability-cve-2025-59689/
- https://www.libraesva.com/security-blog/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-59689
Get alerted when CVE-2025-59689 or the next vulnerability affects your stack