What’s Vulnerable › Vulnerabilities
CVE-2025-59694
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-02 · updated 2026-08-26
- Weakness: CWE-1274
Description
The Chassis Management Board in Entrust nShield Connect XC, nShield 5c, and nShield HSMi through 13.6.11, or 13.7 (patched in 13.6.12 (LTS) and 13.9.0 (STS)), allows a physically proximate attacker to persistently modify firmware and influence the (insecurely configured) appliance boot process. To exploit this, the attacker must modify the firmware via JTAG or perform an upgrade to the chassis management board firmware. This is called F03.
Affected products
- Entrust Nshield 5C Firmware: before 13.6.12; from 13.7.3 before 13.9.0 — fixed in 13.6.12, 13.9.0
- Entrust Nshield Connect Xc Base Firmware: before 13.6.12; from 13.7.3 before 13.9.0 — fixed in 13.6.12, 13.9.0
- Entrust Nshield Connect Xc High Firmware: before 13.6.12; from 13.7.3 before 13.9.0 — fixed in 13.6.12, 13.9.0
- Entrust Nshield Connect Xc Mid Firmware: before 13.6.12; from 13.7.3 before 13.9.0 — fixed in 13.6.12, 13.9.0
- Entrust Nshield Hsmi Firmware: before 13.6.12; from 13.7.3 before 13.9.0 — fixed in 13.6.12, 13.9.0
How to fix
Upgrade to a fixed version: Entrust Nshield 5C Firmware 13.6.12, 13.9.0; Entrust Nshield Connect Xc Base Firmware 13.6.12, 13.9.0; Entrust Nshield Connect Xc High Firmware 13.6.12, 13.9.0; Entrust Nshield Connect Xc Mid Firmware 13.6.12, 13.9.0; Entrust Nshield Hsmi Firmware 13.6.12, 13.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-7gqq-6vwr-4g3v
- https://github.com/google/security-research/security/advisories/GHSA-6q4x-m86j-gfwj
- https://www.entrust.com/knowledgebase/hardware/understanding-nshield-security-advisory-september-2025
- https://www.entrust.com/use-case/why-use-an-hsm
- https://github.com/google/security-research/security/advisories/GHSA-6q4x-m86j-gfwj
Get alerted when CVE-2025-59694 or the next vulnerability affects your stack